Ansys Tutorial: Plate with a Hole

1. This tutorial will perform a 2D linear elastic static analysis of a plate with a hole. The geometry is
shown below
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a.
b. The plate is very thin (plane stress analysis applies)

¢. The Young’s modulus is 200e3 MPa and Poisson’s ratio is 0.3

2. To open ANSYS, go to the Window Menu and select:
a. ANSYS 19.0> Workbench 19.0
b. Note the version number might be different (Workbench is usually at the bottom of the
menu)
3. A Workbench project will open
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4. In the toolbox > Analysis systems menu drag Static Structural into the project schematic window
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b. Save your workbench project
5. Double-click Engineering Data to open the Engineering Data Tab
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6. You generally will have your own materials data or values from handbooks and will not use the

pre-programmed generic materials data.
Below Structural Steel type a new material name: for this example call it “inco625”. Hit
Enter.
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7. Select Inco625
on the left double click Isotropic Elastic
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Now define the Young’s Modulus (E) as 200e3 MPa and Poisson’s ratio as 0.3
In the right corner see Youngs Modulus and Poisons ratio text boxes



Table of Properties Row 3: Isotropic Elasticity 5

A B C

1 Temperature (C) .~ | Young's Modulus (Pa) ~ | Poisson's Ratio | |

e.
f. Use the Dropdown menu to change the units of Young’s Modulus to 200 MPa and insert
the values of Youngs Modulus and Poisson's Ratio
Table of Properties Row 3: Isotropic Elasticity *+ o x
A B i
1 Temperature (C) .~ | Young's Modulus (MPa) ~ | Poisson's Ratio | Bulk Mo
2 2.0E+5 0.3 3.9417
g.

h. No temperature is needed as this analysis will be only at one temperature
i. Close the engineering data tab

& A2:Engineering Data X
neering Data Sources

k. Note that we only defined materials properties that we needed for linear elastic
analysis. Other properties, such as density, thermal expansion coefficient, yield strength,
etc can be supplied but will not be used in a linear elastic static analysis

8. Choose 2D analysis
a. Inthe project schematic right click on Geometry > Properties
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b. .
c. Inthe menu to the right use the dropdown to change Analysis Type to 2D
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f. Close the Properties of Schematic: Geometry window
9. Right Click on Geometry in the project schematic window
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b. Click on New DesignModeler Geometry to open the DesignModeler window (it may take

a second or more to open)
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10. In thé DesignModeler Window
a. Click XY Plane
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¢. Thenclick on the z arrow in the coordinate system to align with the XY plane
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f.  Change your units to millimeters
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11. C|ICk on the Sketch Tab of the Tree Outline Menu
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12. Draw a rectangle in the Graphics Window
a. A click on rectangle in the Sketching Toolbar menu
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13. Dimension the rectangle
a. Now click on the upper edge of the rectangle and drag the dimension label out to your
desired location

b.
c. Inthe details view change the dimension of H1 to 10 mm
I=1| Details of Sketch
Sketch Sketch
Sketch Visibility Show Sketch
Show Constraints? | No
|=/| Dimensions: 1
I-I| Edges: 4
Line |tn19
d_ Line |Ln20

e. Repeat this process for the left side dimension changing V2 to 10 mm

f, m—
Show Constraints? I No
[-)| Dimensions: 2
[ TH1 10 mm
10 mm
g e -

&
h. Use the Zoom to Fit tool in the upper toolbar to center the image —]‘
14. Add the hole

a. Click on the circle icon in the Sketching toolbox Draw tab (you may have to scroll down

using the down arrow to the right)
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b. Dimensions
¢. Draw acircle inside of the rectangle
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15. Dimension the hole
a. Click on Diameter in the Dimensions Tab

@ General
I Horizontal
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c. Click on the circle and drag the dimension to your desired location

D3

d.
e. On the left change the diameter D3 to 2 mm



Show Constraints? | No

-/ Dimensions: 3
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g. Now we will position the circle in space. Click on Horizontal in the Dimensions Tab
Draw
Modify
Dimensions | ~
| General
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i. Click on the left edge of.the rectangle and then click on the left of the circle and then
drag the dimension label to your desired location
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k. Now change H4 in the menu on the left to 4 mm

-/ Dimensions: 4

D3 2mm
H1 10 mm
V2 10 mm

I. ea__ e

m. Click on Vertical in the Dimensions Tab
o

k=4 Horizontal

| I[ Vertical

& Length/Distance
n. | & Radius

0. Click on the top edge of the rectangle and then click on the top of the circle and then
drag the dimension label to your desired location
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2. Now change V6 in the menu on the left to 4 mm (It might be labeled V5, but that’s ok)
|-/| Dimensions: 5 |
| D3 2mm
[ TH1 10 mm
[ H4 4mm
[v2 10 mm
r.
s. Now the whole is centered
6,000 ] 10,000 (mm)
t. H 2500 g

16. Generate the skétch
a. On the upper toolbar click on Concept > Surface from Sketches

te | Concept Tools Units View Help
i | Lines From Points jelect:
__ £ Lines From Sketches = |
| [ Lines From Edges
—1'WA 3D Curve
P |G Split Edges
@ Surfaces From Edges

: gl Surfaces From Sketches

7 | &2 Surfaces From Faces

& Detach
Cross Section L2 pm

b. & vvbiane
c. Inthe details view click on Base Object > Apply

HEGSE
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Details View 2
/| Details of SurfaceSk

Surface From Sketches SurfaceSk
Apply l Cancel

Operation Add Material
Orient With Plane Normal? | Yes
Thickness (>=0) 0mm

Now we want to select the entire sketch
Select the Box Select from the Select menu

Help

JSe'ect IENdINclioRcl |

T} Single Select

e

n/Loft | | WAThin/Surface Q@ Blend
You can now draw a box around the sketch

1 H4
03
fiKilin} 5000 76,600 (mm)
2000 gL

Base Object should say “1 Sketch”, if it does not try Apply and select again

DﬂisViu
=1 Details of SurfaceSk

Surface From Sketches SurfaceSk
Base Objects 1 Sketch
Operation Add Material
Orient With Plane Normal? | Yes
Thickness (>=0) 0mm

Now click generate (in the upper 3 of the screen)
T

JJ -} Generate
oft || WThin/Surf

The sketch should change color
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H000: 5.000 10.000 {mm
o. i 2,500 7.500
p. Save our project and close Design Modeler
17. Open the Modeler
a. Double click on Model in the Project Schematic Window

A
Static Structural

g Engineering Data

=4

2 v

3 @ Geometry v 4

4@ Model D

5 @ setwp ? 4

6 ﬁ Solution ? .,

7 @ Results ? .,
Static Structural

b.
c. It may take a couple seconds to open, but should load your sketch geometry
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@ A: Static Structural - Mechanical [ANSYS Academic Research Mechanical and CFD]
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18. Model Geometry

a.

c

Expand the Geometry option in the project outline

IJ Filter: |Name ﬂ
B ad>=ea i

l ----- v X Coordnate Systems
Click on Surface Body

Project
. Model (A4)

l ----- VIR A Coordnabe Systems

In the Detalls of the Surface Body window click on Assignment

Thickness 1.e-003m
Thickness Mode Refresh on Update
Behavior None

(= Material
Assignment
Nonlinear Effects Yes
Thermal Strain Fffertc | Vec

Assign Inco625 Material to the Geometry

Behavior | None
[=1| Material
CETTT— ¢ |
Nonlinear Effects Yes :ﬁ') New Material...
Thermal Strain Effects | Yes £ Import... E

[— incob25

Below Assignment change Nonlinear Effects and Thermal Strain Effects both to NO
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‘ Assignment |inco625
'Nonlinear Effects bNo
Themal tain Efecs I8
[+/| Bounding Box
j, | Properties
k. Under Details of Geometry>definition keep the 2D behavior as plane stress (as the plate
is very thin)

19. Finite Element Mesh
a. Click on Mesh in the project outline
o, W Surfa
-4 Coordinate
o l,‘£® MeSh
=-9l=] Static Str

¢. Inthe Details of Mesh menu you could change the Physics Preference to other types of

systems but DO NOT, leave it as Mechanical
-/ DISplay

' Display Style |Body Color
- Defaults
Physics Preference LUEGERITE]

Mechanical
Nonlinear Mechanical

Element Order

® [ Sizing Electromagnetics
/| Quality CFD
# Inflation Explicit
t Hydrodynamics
+| Advanced
d. |= statistics

e. Inthe Details of Mesh menu change the element order (l.e., the order of the element
shape function) to linear

- Defaults
Physics Preference | Mechanical

Element Order
E_Sizing
H‘Quality

f f]ylnﬂation
Right Click on Mesh and select Method

| Surface Body

/X Coordinate Systems -
/%

Program Controlled
Program Controlled

Quadratic

-8 o
o ; =} Update @, Sizing
15 Refi t
h =/ Generate Mesh A Refinemen

i. Inthe Details of Automatic Method Menu click geometry, select the plate to the right,
then click apply

-|| Scope
Scoping Method { Geometry Selection
'Geometry ‘1 Body
j. =l Nafinitinn

k. The plate should change color and say Automatic Method in the upper left corner
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For method select Quadrilateral dominant

Geometry [ 1 Body

[=| Definition

Suppressed No
Quadrilateral Dominant v
Flamant Nrdar llca Rlahal Sattinn

For Free Face Mesh Type select All Quad

Method Quadrilateral Dominant

Element Order Use Global Setting

Free Face Mesh Type | All Quad

v T

t. Under bo

“_, W@ Surface Body

We will now set an approximate element size
Right click mesh and select sizing

——rr——y

Coordinate Systems

@ s
# Ut o

Details of "Body Sizing” - Sizing

|-/ Scope

Scoping Method | Geometry Selection

Geometry 1 Body

u. [=I| Definition

v. Changee

lement size to 0.0001

Geometry [1 Body

S

Definition

Suppressed No

Type Element Size

LT o
w. = Advanced

X. Right click on mesh and select Generate Mesh (this may take a second or two)
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= N wEumeu y
~--- 4 W Surface Body
- ,/A Coordinate Systems

& @ Insert =
=% Updat
-/ Update
=228
B
y. Preview %

z. lItis ok if a few triangles are used with the quad elements, you should get a mesh that
looks something like this (In general 2D meshes are cheap computationally and should
be very fine, 3D meshes are much more expensive computationally and might need to
be coarser)

aa.
bb. Details of Mesh > Statistics will show how many elements and nodes

20. Apply Boundary Conditions (l.e. loads and constraints)
a. Apply the load. Right click on Static Structural an select Insert > Pressure

Name > @] Standard Earth Gravity
2] P> el 4l @3, Rotational Velocity
roject @, Rotational Acceleration
| Model (A4)

/& Geometry ppressure |

i W Surface Body @, Hydrostatic Pressure

# ,/A Coordinate Systems @, Force

7 '/% Mesh G‘. Remote Force
Q,. Bearing Load
“j Bolt Pretension
q, Moment
.] Thermal Condition

b. Lol

c. Select the upper edge of the plate
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e. Click Geometry > Apply (if it does not work, try it again)

f.
g. Change the magnitude to —100e6 Pa (a ramped load is ok for this analysis)
Details of "Pressure”
=/ Scope
Scoping Method | Geometry Selection
Geometry 1 Edge
| )| Definition
Type Pressure
Define By Normal To
Applied By Surface Effect
-1.e+008 Pa (ramped)
h. Suppressed No
i. Apply a y-constraint on the bottom. Right click on Static Structural an select Insert >
" Bolt Pretension
&, Moment
@) Thermal Condition
@ Joint Load
& Fixed Support
€ Clear Generated Data Du:’»plm;ernent
j b Rename (F2) @ Remote Disblacement
k. Select the lower edge of the plate

|.  Click Geometry > Apply (if it does not work, try it again)
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S.

t.

Change the y-component displacement to O (leave the x-component free)

-/| DenmnITuon
Type Displacement
Define By Components
Coordinate System | Global Coordinate System
X Component Free

W Componert CENEUE

Apply x-constraint on the right edge. Right click on Static Structural an select Insert >
Displacement
Select the right edge of the plate

Click Geometry > Apply (if it does not work, try it again)
o

Change the x-component displacement to O (leave the x-component free)
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Scoping Method | Geometry Selection

Geometry 1 Edge

[=/| Definition
Type Displacement
Define By Components

Coordinate System | Global Coordinate System
| PETLELTNISE 0. m (ramped)

Y Component Free

Suppressed No

v. Intersection of bottom and left edge. The intersection of the bottom and left edge must
have both an x-constraint and y-constraint
w. Right click on Static Structural an select Insert > Fixed Support (l.e. no displacement in

v, Beanng Load
" Bolt Pretension r
q, Moment

@) Thermal Condition
@ Joint Load

¥ vecisiooor

3, Displacement

y. Change the selection method to Vertex

Units Tools Help H

> EmEm® W

5 Close Vertices 1
-ation v .Convert -

aa. Select the lower right corner

bb.
cc. Click Geometry > Apply (if it does not work, try it again

21. Solve
a. Now tell ANSYS what results you want. Lets select y-displacement, y-normal stress, and
Equivalent (l.e. von Mises) stress
b. Right click on Solution and select Directional Displacement
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»

g.. Char&gceu(l)"rlciln,tation to Y-AxisH" uuu.c:"”
=I| Definition J
Type Directional Deformation
Orientation Y Axis
By Time
.. Display Time \ Last

f.  Right click on Solution and select Stress > Normal
-/, FIXea Support |

B .:@

Strain

>
>
'.}' Evaluate All Results : .
“Solution (A6 = © ouivaicnt (von-Mises)
»
>

ve Mesh Refin 2] Clear Generated Data Energy . Maximum Principal

finement Loo| AP Rename (F2) Linearized Stress @, Middle Principal

nent Depth | ™) Group All Similar Children Stress Tool | @ Minimum Principal

ation - @ Maximum Shear
A Open Solver Files Directory Fatigue » B Intensity -

opsed ine| ( Worksheet: Result Summa Bl ool [
@ < Contact Tool 4 q’ Noema

g. .Memory Used ™ T276" W5 Chaar

h. Change Orientation to Y-Axis
i. Right click on Solution and select Stress > Equivalent (von Mises)

j.  Right Click on Solution and select Solve
e A, LISpIacement

P, Displacement 2
P, Fixed Support

E]"::@
i8] 5ol Insert »

#-soion | - EXY

itive Mesh Refineme:

: 2] Clear Generated Data ——
Refinement Loops
k. T M s
22. Results
a. Click on each result to displace the contour

vV M —Tm—— e —

- /3, Fixed Support
= ,@ Solution (A6)
- /4] Solution Information
- /& Directional Deformation

B Y orma Soess
s

Equrvalent Stress
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For a cleaner plot without elements click Edges and changes to No Wireframe
ASSEmMDIy Lenter v o]

v " = ‘ MmNy | [23)Probe \ Disph
U JNo WireFrame
‘ Show Undeformed WireFrame

@ Show Undeformed Model
‘. Show Elements

Use the Pan button to move the plate near the legend
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1.8155e8
149098
1.1663e8
841787
5.1723e7
1.9267e7 Min

g.
h. The analytical solution is a stress concentration factor of 3.0, so the peak stress should
be 300 MPa, the predicted stress is 311 MPa.
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